End User System Requirements

LightSpeed VT is fully compatible across all common computing  and mobile devices including: desktop computers, laptops, tablets and mobile phones with modern browsers. No additional plugins or custom software installation is necessary. The minimum and recommended “System Requirements” may change minimally as needed as browsers, operating systems and LightSpeed VT application updates are made.

  Desktop Requirements   Mobile Requirements
Internet Connection: Broadband connection with 500+ Kbps LTE/Broadband connection with 500+ Kbps 1
Operating System: Windows Users:
Microsoft Windows XP, Vista, Windows 7 or newer

Mac Users:
Mac OS X v10.5 “Leopard” or newer
Android Users:
Android 5.1 “Lollipop” or newer 2

iOS Users:
iOS 10.0 or newer 2
Web Browser: 3 The latest version is recommended for all browsers

  • Internet Explorer (Version 11 or higher)
  • Google Chrome (Version 34.x or higher)
  • Safari (Version 5 or higher)
  • Firefox (Version 32.x or higher)
  • Microsoft Edge
Screen Resolution: Responsive Design will accommodate all desktop monitor sizes, modern tablets and phones. There are select few pages in the Admin Reports that require 1024×768 or higher; an alert message will prompt users, if their screen resolution does not meet this requirement.
Javascript: Enabled Enabled
Cookies Enabled: Enabled Enabled
Proxy Servers: Connecting through a proxy server could affect system performance due to certain caching settings of your proxy server. It is recommended that you do not use a proxy server connection.
1 Cellular data charges may apply.
2 Android 4.0, 4.1, 4.4 and iOS 9 will work on all areas EXCEPT the Interactive Videos.
3 The Adobe Flash Player browser plugin may be required on some pages that contain older custom content.